在联网的模式下:

yum install kernel

默认会安装centos仓库上最新的版本的kerenl, 有时候可能会和我们使用的不匹配,这样就需要指定版本,通过下面的方法指定:

yum install kernel-4.14.0-115.2.2.el7a

同样可以安装kernel-devel的方法也相同

yum install kernel-devel-4.14.0-115.2.2.el7a